How to use the GAN art CLI

As usual with dae your first try at the CLI GAN generated art results in a load of obscure meaningless Java errors

This is, of course, because the person testing it had an example command line that was correct (so it passed testing). Relying of just the output from the CLI to tell you what to type results in some meaningless Java error more often than anything useful.

So - here’s the missing example they should have given us…

Extract then open a command prompt, e.g. Powershell, wherever you put it and type

.\DeepArtEffectsCli.exe generate -name artwork -output test.jpg

The only current option for -name is artwork and even thought you cant ask for anything else if you miss it out you’ll get a meaningless Java error

The -output switch must also be supplied, this should be the name of the file you want to save as despite it saying its the path where you want the image to be output (which is something else), Missing this or getting it wrong will result in a meaningless Java error

The -extension switch is optional which is just as well as it seemingly has no effect - the filetype is picked up from the filename you give it with the -output switch.

Until DAE start doing proper testing expect your favourite obscure meaningless Java error to be a standard feature.

They once sent me an early release, I immediately found an error in the GUI version which they fixed - not had an early release since (and, yes. I’ve mentioned the meaningless Java error issue many times)

Perhaps you (or someone) can help me debug this meaningless java error:

I made a small batch file to run the “generate” command multiple times. It worked before but not now.

Here is the command: FOR /L %%y IN (1, 1, 10) DO DeepArtEffectsCli.exe generate -name artwork -output %%y.png

Here is the result:
C:\Users\Rick\Downloads\DeepArtEffectsCli>DeepArtEffectsCli.exe generate -name artwork -output 1.png
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by nu.pattern.OpenCV$SharedLoader (file:/C:/Users/Rick/Downloads/DeepArtEffectsCli/DeepArtEffectsCli.exe) to field java.lang.ClassLoader.usr_paths
WARNING: Please consider reporting this to the maintainers of nu.pattern.OpenCV$SharedLoader
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
Exception in thread “main” java.lang.IllegalArgumentException: An error downloading generated Image occured.
at com.deeparteffects.desktopapp.a.a.d.a(Unknown Source)
at com.deeparteffects.desktopapp.a.a.a(Unknown Source)
at com.deeparteffects.desktopapp.a.a(Unknown Source)
at com.deeparteffects.desktopapp.MainLauncher.main(Unknown Source)

C:\Users\Rick\Downloads\DeepArtEffectsCli>DeepArtEffectsCli.exe generate -name artwork -output 2.png
WARNING: An illegal reflective access operation has occurred
…, etc.

I learned long ago to ignore the warnings. But this error is fatal because no output file is written.

It doesn’t matter whether I do or don’t use the full path in the “-output” field. It doesn’t matter whether I do or don’t enclose the path in quotes. It doesn’t matter whether I use the .png or .jpg extension on the output file. I have tried dozens of options to no avail.

It puzzles me that I could make this script work before but not now.

Do I need to use a specific version of Java in order to make this work?

What is going on? I have spent several frustrating hours trying to get this to work.

Can anyone help me?


Hello Peardox,

We are letting you know that we’re currently contacting our devs to help you solve this issue.

We will update you as soon as possible.


Over two years to acknowledge the problem…