Linux installation hangs


#21

Well, I tried the deep-art-effects-linux-1.2.5-gpu.deb but it doesn’t work I’m afraid.

I installed libcudnn8_8.0.4.30-1+cuda10.1_amd64.deb that I got from the nvidia site. They didn’t have a version for 20.04, so I chose the 18.04 version.

DAE opens up fine but hangs after opening an image, with a window saying
“Downloading Style…
96/100 - (0:00:00 remaining)”

For your information here is a selection of the messages generated on the console:-

13:50:06.397 [main] INFO  com.deeparteffects.desktopapp.Main - Starting Deep Art Effects for Desktop - GPU
OS: GNU/Linux Ubuntu 64Bit Version: 20.04.1 LTS
RAM: 9638MB of 15945MB available
CPU: Intel64 Family 6 Model 158 Stepping 10 with 12 cores
DISK: 59099MB usable of 63211MB free of 80122MB total space
%JAVA HOME%:/usr/lib/jvm/java-6-sun-1.6.0.03
%PATH%: /home/psrwebs/perl5/bin:/home/psrwebs/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr
/games:/usr/local/games:/snap/bin
13:50:06.480 [main] INFO  com.deeparteffects.desktopapp.Main - Running on 64bit - Linux!
13:50:06.481 [main] INFO  com.deeparteffects.desktopapp.Main - JAVA: 1.8.0_265 - 64bit JVM
13:50:06.488 [main] DEBUG com.deeparteffects.desktopapp.Main - User Agent: Deep-Art-Effects-Desktop/1.2.5 (linux)

13:50:06.709 [main] DEBUG com.deeparteffects.rendering.renderable.a.b - initializing OpenCV…
OpenJDK 64-Bit Server VM warning: You have loaded library /tmp/opencv_openpnp1620550131649086786/nu/pattern/opencv/
linux/x86_64/libopencv_java320.so which might have disabled stack guard. The VM will try to fix the stack guard now
.
It’s highly recommended that you fix the library with ‘execstack -c <libfile>’, or link it with ‘-z noexecstack’.

13:50:07.520 [JavaFX Application Thread] DEBUG com.deeparteffects.desktopapp.gui.c - Window initialized!
Sep 29, 2020 1:50:07 PM com.deeparteffects.core.d.a b
WARNING: Could not create Session for : render_segmentation.model  
redownloading on use! Delete corrupt model
Sep 29, 2020 1:50:07 PM com.deeparteffects.core.e.d a
INFO: Watching files matching [*.model] under /home/psrwebs/.deeparteffects/assets for changes.
Sep 29, 2020 1:50:07 PM com.deeparteffects.core.e.d run
INFO: Starting file watcher service.
13:50:07.575 [Thread-6] INFO  com.deeparteffects.rendering.c - DeepArtEffects Core initialized!
13:50:07.668 [JavaFX Application Thread] DEBUG com.deeparteffects.desktopapp.gui.c - checking License…
13:50:07.668 [JavaFX Application Thread] DEBUG com.deeparteffects.desktopapp.gui.c - TRID: 28c76f03be49c0ff
13:50:08.016 [Thread-13] INFO  com.deeparteffects.desktopapp.gui.c - newest version: true
13:50:08.222 [Thread-12] DEBUG com.deeparteffects.desktopapp.c.a - tracked
13:50:08.563 [Thread-11] DEBUG com.deeparteffects.desktopapp.c.a - track w/ param
/mnt/scratch13:50:14.647 [JavaFX Application Thread] INFO  com.deeparteffects.desktopapp.util.c - /mnt/scratch

13:50:26.209 [JavaFX Application Thread] DEBUG com.deeparteffects.desktopapp.b.a - opening image from file: /media/
psrwebs/USB2/img_1419.jpg
13:50:26.253 [JavaFX Application Thread] DEBUG com.deeparteffects.desktopapp.b.a - successfully opened image from f
ile!
13:50:26.622 [Thread-15] DEBUG com.deeparteffects.desktopapp.c.a - tracked
Sep 29, 2020 1:50:28 PM com.deeparteffects.core.d.b a
INFO: Add new model render_segmentation.model
Sep 29, 2020 1:50:28 PM com.deeparteffects.core.d.b a
WARNING: Could not create Session for : render_segmentation.model  
redownloading on use! Delete corrup model


#22

Just to be sure as CUDA messes with things too

Theoretically you need CUDA 9.0 - specifically. Last time I did that it involved an OS re-install tho which is either painless or devastating depending on your setup


#23
  • 2            /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java   1081      manual mod

It seems to have kept the choice I made previously.

I’m not sure I want to re-install the OS


#24

Well, actually it’s only CUDA that needs attention. Problem is that it doesn’t like uninstalling too much. I uninstalled CUDA 10 a while back but then on trying to install CUDA 9 it said I already had CUDA 10 and chickened out of what it saw as a downgrade (even tho I’d uninstalled v10)

It’s OK to have lots of versions of CUDA installed (disk space allowing) but it wants you to install then in order (and keeps offering to remove the old versions…). I gave up looking for why CUDA thought it was still installed an just re-did the OS (a fairly simple choice in my case though it did take a while to backup everything another time I did it)

You might be able to get GPU on Windows - depends if you’ve installed CUDA yet. If not start with v9.0 then if you need you can always add 9.1, 10, 10.1 etc


#25

Well, I think I’ll have to give up on the GPU version for linux. I did some researching and found that it was OK to have multiple versions of CUDA installed, all that was needed was the right symbolic link in place. So I tried installing the 9.0 toolkit. However this failed saying that I had an incompatible compiler 9.3.0. It suggested using the --override option, but this option was not recognised. I think, short of finding a cookbook on how to install 9.0 on Ubuntu 20.04, installing 9.0 is above my pay grade :cry:

So I’ll re-install the CPU version, though because it’s much slower I may have to be resigned to having to keep booting into Windows 10. Pity. But many thanks for helping me get the CPU version working on 20.04


#26

That was pretty much how I thought CUDA on Ubu 20 would go.

The trick is to completely obliterate CUDA from your system. This can be a rather bad experience as well.

One suggestion I have is to try making a fresh Ubu 20 install on an external USB 3 HD (don’t bother even trying with anything slower than USB 3). You have to be careful when doing this of course - don’t wanna wipe your main OS, I used this method when testing out all the versions of Linux on peardox.com. My main laptop has a (crap but supported) GPU with Win10 as the main OS.

I was going to write a guide to installing everything that way as it can be a useful option, particularly as it speeds up render times as there’s no Windows eating all the resources.

Something else I did was get DAE working via command-line on Linux on my X86_64 (plus my Jetson Nano and Raspberry Pi 4) - useful for batch processing. The Mac hacky command-line ended up being the most sensible to leave running for an extended period but I gave up on that owing to memory leaks eating all my Mac’s memory 5 days into a long video encode… What I had looked cool, I just couldn’t go through the pain of restarting it in smaller batches.