Linux installation hangs


#1

I have Ubuntu 20.04 with CUDA 10.1 and an nVidia card.

I have just downloaded and installed the Linux version. However, although the logo appears it never gets past this point and the circular loading cursor just rotates endlessly.

During installation with gdebi the following were installed:
libopenjfx-java libopenjfx-jni openjdk-8-jre openjdk-8-jre-headless openjfx openjfx-source

How can I get it working, or do I need to use the Windows version? (I have a dual boot machine, or I could use WINE)


#2

Ubuntu 20 is not supported so far.

Please have a look here for detailed installation instructions:
https://peardox.com/linux


#3

I’m just checking this on a fairly new (installed OS a month or so ago) to see what the score is.

One thing I note is that you’ve already installed CUDA 10.1. Unless @cedric has updated the CUDA support this will definitely not work as DAE requires (last time I checked and still documented) version 9.0.

There is a work-around but it’s messy - I’ll get to that once I’ve tried out software DAE on Ubu 20.04


#4

I take it you’re running on an x64 CPU?


#5

vendor_id       : GenuineIntel
model name      : Intel® Core™ i7-8700 CPU @ 3.20GHz

12 cores.


#6

Graphics is: GeForce GTX 1070 Ti
CUDA Cores: 2432
NVIDIA Driver Version: 450.66


#7

I’ll get to GPU after I see if DAE runs

My instructions for 19.04 won’t work on 20.04 - had to hack the deb file a bit to get things installed.


#8

Well, I wasn’t sure that was going to work but it did…

This is DAE running on a way below spec 4Gb Atom CPU (pile of junk a friend gave me as a spare). The instructions are rather involved as I had to modify one of the packages DAE requires to run - basically I changed its dependencies to make it install OK (so it’ll only work with these modified versions)

I’ll add a Ubuntu 20.04 installation page to peardox.com in a little bit.

If you’ve installed Java etc on your PC then things will be more complicated as you’ll have the wrong version of Java - 100% guaranteed.

When it comes to GPU as I recall you can switch which version of CUDA you’re using but there’s a potential problem here as you’ve already installed 10.1. Basically that may need completely removing (which is harder than it sounds) - we’ll worry about that after you get a fixed Java installation…

It’s possible the GPU will work - depends on what changes they’ve made to CUDA support in DAE (don’t hold yer breath)


#9

Great. That’s good news. Thanks.

With Java, the gdebi installation of the DAE package installed various java packages as it went along. I assumed these were required dependencies and so would be the right ones.


#10

Hardly anyone uses Java on Desktops…

Anyway - Ubuntu 20.04 install instructions (involves command line) https://peardox.com/linux/ubuntu-20-04/

This is the user-friendly version of what I did to get DAE running on Ubu 20.04

There are some minimally altered system packages (altered dependencies). Had to do this to get the ancient version of Java DAE uses to install the JFX package.

I could have written DIY instructions on making the packages compatible - that would definitely be a bit much to expect the average user to do properly though. At least the instructions provided work…


#11

Many thanks, I’ll give it a try. Do I need to uninstall the existing, non-working, version, or will it just be overwritten?


#12

Not overly sure what’ll happen with Java until you try it as you’ve got stuff already installed

DAE will replace itself then if that works you can try the GPU version as we’ll see what happens there


#13

OK. I followed your very clear instruction (though NB: cd dae-ubuntu-20.04-java-fix.tgz needs to be cd dae-ubuntu-20.04-java-fix)

However, it still hung after the logo. I started it from the command line using
sh /opt/deeparteffects/start.sh

and noted the following messages:
Exception in thread “main” 17:22:36.670 [main] ERROR com.deeparteffects.desktopa
pp.util.c - Exception in thread “main”  
java.lang.UnsatisfiedLinkError: no opencv_java320 in java.library.path: [/usr/ja
va/packages/lib, /usr/lib/x86_64-linux-gnu/jni, /lib/x86_64-linux-gnu, /usr/lib/
x86_64-linux-gnu, /usr/lib/jni, /lib, /usr/lib]17:22:36.670 [main] ERROR com.dee
parteffects.desktopapp.util.c - java.lang.UnsatisfiedLinkError: no opencv_java32
0 in java.library.path: [/usr/java/packages/lib, /usr/lib/x86_64-linux-gnu/jni,
/lib/x86_64-linux-gnu, /usr/lib/x86_64-linux-gnu, /usr/lib/jni, /lib, /usr/lib]

Incidentally, there are also a lot of messages of the form:
17:22:37.215 [Thread-1] INFO  com.deeparteffects.rendering.style.ArtFilter - the
style “ed72c2f2-1b90-11e7-afe2-06d95fe194ed” is out of date!


#14

I may be confused about the DAE versions. I can only see one download option, but you imply there are CPU and GPU versions.

what I used was: deep-art-effects-linux-1.2.5.deb


#15

Oops re docs - too much cut + paste :slight_smile: I’ll go fix it now…

That error means that your Java version is wrong (thought this may happen)

Type this…

java -version

You want to see this…

openjdk version "1.8.0_265"
OpenJDK Runtime Environment (build 1.8.0_265-8u265-b01-0ubuntu2~20.04-b01)
OpenJDK 64-Bit Server VM (build 25.265-b01, mixed mode)

You’ll see something else - so try this…

sudo update-alternatives --config java

Look for a line with java-8-openjdk-amd64 on it - there’s a number at the start of the line - select that one. I can’t actually see the results of the command here as I’ve ONLY got the right version installed.

There are two download options - the GPU version is below the main one marked as beta. Let’s get the non-GPU one working first… The GPU version will most likely have problems cos of Cuda 10.1 - worth getting working though as the speed increase is crazy.


#16

gives:
openjdk version “11.0.8” 2020-07-14
OpenJDK Runtime Environment (build 11.0.8+10-post-Ubuntu-0ubuntu120.04)
OpenJDK 64-Bit Server VM (build 11.0.8+10-post-Ubuntu-0ubuntu120.04, mixed mode, sharing)

sudo update-alternatives --config java
gives:

There are 2 choices for the alternative java (providing /usr/bin/java).

 Selection    Path                                            Priority   Status

  • 0            /usr/lib/jvm/java-11-openjdk-amd64/bin/java      1111      auto mode
     1            /usr/lib/jvm/java-11-openjdk-amd64/bin/java      1111      manual mode
     2            /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java   1081      manual mode

should I choose 2 ?


#17

That’s the one

Select 2 and DAE will theoretically work


#18

Great. That seems to work, except that it won’t accept my product key.

This worked when I tried the Windows version. Do I need a separate key for the Linux version? If I delete the Windows version would the product key then work for Linux? Help would be appreciated on this.

I tried the free trial and that works nicely.


#19

You’ve got to release your key in order to use it again

Just go to the main site, log in then select Product Key from Profile and click on De-activate

You can then use it for your new Ubuntu version

I noticed in the past that Linux is measurably faster than Mac which in turn is faster than Windows

Once you’ve got your key in Linux version give the GPU version a go - if CUDA causes problems then you can just re-install the non-GPU version again for now.

My key runs out Nov 5th (hello @Cerdic…) so you caught me at a opportune time


#20

Thanks. All is now well. I really appreciate your help.

I’ll now try the CUDA version and see what happens.