RPM version for systems other than Ubuntu / Debian


#1

Hi

Currently on the website there is an installation version for Linux in DEB format. This format is intended for Debian and its derivatives. Unfortunately, installing DEB on non-Debian systems can be problematic. This is my case.

I have Opensuse 15.2. This distribution does not support the DEB package by default. That’s why I converted to RPM with the help of the ALIEN package. Unfortunately, the program installs but does not start.

Is there any official Linux version that is in a format other than DEB? Or maybe there is an official guide on how to install the program on distributions other than Debian / Ubuntu?


#2

Thanks for your questions.

Currently there is nothing official for that I am sorry to say @kompania
Just a thought, as our program is java based, make sure that’s present.
Other than that I don’t know what dependencies might be missing to make it run on your system


#3

Actually DAE won’t work on anything other than Java-8 which is very old so don’t “make sure that’s well updated and present”

I’ll have a quick bash at seeing if I can get it running on OpenSuse 15.2 (I’ve got RPM systems working before) - as I remember Alien worked fine but Java needed attention.


#4

Installed OpenSuse in a VM and sure enough it comes pre-installed with Java 11 - that will cause DAE not to start

Not used a RPM-based system in ages but the solution should be to replace Java 11 with Java 8, problem is OpenJava screwed up their JavaFX implementation’s compatibility when they started using versions above 8.

On Debian systems I get around this by using old packages where the JFX is good - can;t find a good one for RPM system.

A solution is to use the Oracle/Sun Java 8 which has some horrible license - I’ll give that a go and see if it works


#5

Well, that was a lot easier than I thought it’d be!

You’ve already used Alien to convert the deb to rpm and installed it - now you just need to fix Java

Go to https://www.java.com/en/download/manual.jsp - read the scary license then scroll down and download the Linux x86_64 RPM package. Install it - it warned me about package sig so I clicked on ignore and installed it anyway.

Just to be sure I opened a terminal and typed ‘java -version’ - amazingly it had worked and I was on 1.8.0 (never had it work so easily before)

I installed DAE and the results (I’m using a VM to test so ignore the Windows stuff, that’s a fully functional OpenSuse in the following image…)

Tada!

The remove watermark banner is cos I’m using the trial (I’m not going thru the hassle of switching the license to a system I’m going to wipe in 10 mins)

Note that system updates may decide to go and “upgrade” Java back to Java 11, if DAE don’t work just check with ‘java -version’ to check you’re on 1.8 - something like this…

[email protected]:~> java -version
java version “1.8.0_281”
Java™ SE Runtime Environment (build 1.8.0_281-b09)
Java HotSpot™ 64-Bit Server VM (build 25.281-b09, mixed mode)
[email protected]:~>