Holy Cuda 10.0, Batman


#1

Oh my god, I just got DAE working with Cuda 10.0 - this machine has no Cuda 9 on it!

Experimentation time…

Hmm - not even optimized it for the GPU Yet - shoould boost the speed if I do (takes ages to build the required DLL)…

Getting this far has been three days worth of frustration (plus many more days worth of previous failed attempts) to get to this not even knowing if it was gonna work - I’ll stick an optimized build on tonight to see what difference it makes.

Just wiped my laptop - so thats got nuffin, I’ll have to try that next…


#2

Well, laptop worked - just started building the fully-specced version that handle all cards up to 2080, Tthis will take hours - started at midnight on the dot, if no errors it’ll finish sometime later (possibly much later - they do warn about this)


#3

do you have a git for this project?


#4

https://github.com/tensorflow/tensorflow but it’s very broken and fixing it was a matter of lots of trial + error with some luck finding a specific bug report that got it working. From a blind start I’ve been playing with this on and off since Beta 1.2.7 came out and just had another majot push at it cos if the Russian PC (which finally worked)

The all-cards version took four hours to compile last night (ran out of disk space at one point) but it works perfectly with Cuda10 - think is the DLL is huge so I’m doing card-specific builds ATM as the DLLs will be a lot smaller.